5th December 2022

“The license for ePolicy Orchestrator is invalid” and “Login failed. The login is from an untrusted domain and cannot be used with Integrated authentication” Error and Solution

When connecting to Mcafee EPO, “The license for ePolicy Orchestrator is invalid“, “Error: DB Server Key Check Failed” and “A database error occurred while getting license information. Make sure your database server is currently running.” errors are received.

Error “The license for ePolicy Orchestrator is invalid”

The license for ePolicy Orchestrator is invalid

Error: DB Server Key Check Failed

A database error occurred while getting license information. Make sure your database server is currently running.
The license for ePolicy Orchestrator is invalid
The license for ePolicy Orchestrator is invalid

 

Error “Login failed. The login is from an untrusted domain and cannot be used with Integrated authentication”

Then, when we try to access the Mcafee EDR database, we get the error “Login failed. The login is from an untrusted domain and cannot be used with Integrated authentication. (Microsoft SQL Server, Error: 18452)“.

Login failed. The login is from an untrusted domain and cannot be used with Integrated authentication
Login failed. The login is from an untrusted domain and cannot be used with Integrated authentication

 

When we look at the details of the error, you can look at the explanation below.

database 
=================================
Cannot connect to x.x.x.x.
===================================
Login failed. The login is from an untrusted domain and cannot be used with Integrated authentication. (.Net SqlClient Data Provider)
------------------------------
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=18452&LinkId=20476
------------------------------
Server Name: x.x.x.x
Error Number: 18452
Severity: 14
State: 1
Line Number: 65536
------------------------------
Program Location:
   at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, SqlCredential credential, Object providerInfo, String  

The login is from an untrusted domain and cannot be used with Integrated authentication
The login is from an untrusted domain and cannot be used with Integrated authentication

 

The solution to the Error

When we searched for the solution to the errors, we noticed that the Active directory verification policies changed with the update and it conflicts with the policies we made, so we saw that NTLM does not allow the connected applications and we saw that the errors were fixed when we corrected these policies. These improvements took some time, but we did it successfully.

LEARN MORE  Ansible installation and configuration on Centos 8

 

Leave a Reply

Your email address will not be published. Required fields are marked *