2nd December 2022

Link Aggregation / VLAN (Access-Trunk) on Huawei Devices

1. Link-Aggregation

  • Link-Aggregation for S1

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]sysname S1

[S1]interface Eth-Trunk 1

[S1-Eth-Trunk1]mode lacp-static

[S1-Eth-Trunk1]quit

[S1]interface GigabitEthernet 0/0/9

[S1-GigabitEthernet0/0/9]eth-trunk 1

[S1-GigabitEthernet0/0/9]interface GigabitEthernet 0/0/10

[S1-GigabitEthernet0/0/10]eth-trunk 1

 

  • Link-Aggregation for S2

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]sysname S2

[S2]interface Eth-Trunk 1

[S2-Eth-Trunk1]mode lacp-static

[S2-Eth-Trunk1]trunkport GigabitEthernet 0/0/9

[S2-Eth-Trunk1]trunkport GigabitEthernet 0/0/10

2. Create VLANs

  • Create a Link-Aggregation between S1 and S2
  • Create trunk port for Eth-Trunk 1
[S1]interface Eth-Trunk 1

[S1-Eth-Trunk1]port link-type trunk

[S1-Eth-Trunk1]port trunk allow-pass vlan all

[S2]interface Eth-Trunk 1

[S2-Eth-Trunk1]port link-type trunk

[S2-Eth-Trunk1]port trunk allow-pass vlan all

 

  • Create Vlan3 for the interface G0 / 0/13 of the S1 and Vlan4 for the interface G0 / 0/1 and assign VLANs

[S1]interface GigabitEthernet 0/0/13

[S1-GigabitEthernet0/0/13]port link-type access

[S1-GigabitEthernet0/0/13]quit

[S1]interface GigabitEthernet 0/0/1

[S1-GigabitEthernet0/0/1]port link-type access

[S1-GigabitEthernet0/0/1]quit

[S1]vlan 2

[S1-vlan2]vlan 3

[S1-vlan3]port GigabitEthernet 0/0/13

[S1-vlan3]vlan 4

[S1-vlan4]port GigabitEthernet 0/0/1

 

  • Display the Vlan configuration for S1 and S2.

<S1>display vlan

The total number of vlans is : 4

—————————————————————————

U: Up;         D: Down;         TG: Tagged;         UT: Untagged;

MP: Vlan-mapping;               ST: Vlan-stacking;

#: ProtocolTransparent-vlan;   *: Management-vlan;

—————————————————————————



VID Type   Ports

—————————————————————————

1   common UT:GE0/0/2(D)     GE0/0/3(D)     GE0/0/4(D)     GE0/0/5(D)

                              GE0/0/6(D)     GE0/0/7(D)     GE0/0/8(D)     GE0/0/11(D)

                              GE0/0/12(D)     GE0/0/14(D)     GE0/0/15(D)     GE0/0/16(D)

                              GE0/0/17(D)     GE0/0/18(D)     GE0/0/19(D)     GE0/0/20(D)

                              GE0/0/21(D)     GE0/0/22(D)     GE0/0/23(D)     GE0/0/24(D)

                       Eth-Trunk1(U)

2   common TG:Eth-Trunk1(U)

3   common UT:GE0/0/13(U)

                       TG:Eth-Trunk1(U)

4   common UT:GE0/0/1(U)

                        TG: Eth-Trunk1(U)

 

LEARN MORE  What is Data Loss Prevention (DLP)? Why should we use?

Leave a Reply

Your email address will not be published. Required fields are marked *